SMB Multichannel not listening on all SMB interfaces

Hello

So i noticed on our Dataon S2D cluster that not all interfaces had a SMB Listener.

You can get the output for that from Netstat -xan

You will see something like this

If you have 2 interfaces it should be like

What i did was i disabled the interface that did not have a listener and enabled it again and suddenly i had 2 interfaces when i run netstat -xan.

This is either a bug related to bootup or something with SMB binding. Il update this post as soon as i have something to share about this. But for now after a reboot i will need to disable the interface and enable it again.

Update

It’s confirmed by 2 sources that it’s a known issue. It’s a NIC driver, Windows Server missmatch. I will try and get an update on this as soon as possible.

2 thoughts on “SMB Multichannel not listening on all SMB interfaces

  • May 30, 2017 at 2:16 pm
    Permalink

    Hi Jan-Tore, thx for bringing this up to the public. I am experiencing the same issue with Mlx adapters. Not sure if this is related to the Hardware/Driver or a Microsoft issue. Do you have any update on this? thx, Gerold

    Reply
    • June 2, 2017 at 4:05 am
      Permalink

      As off now i have not heard anything back about the issue. But i did setup a new cluster in april and i did not have any issues there. But that was with Mellanox ConnectX3 cards and not ConnectX4 cards. But the cluster with the issue has not been rebooted for a while. Im going to patch it once im back from holiday.

      Il update this post if i find anything new.

      JT

      Reply

Leave a Reply

Your email address will not be published. Required fields are marked *